diff options
author | algebro | 2019-01-19 15:17:17 -0500 |
---|---|---|
committer | algebro | 2019-01-19 15:17:17 -0500 |
commit | ae89fbcb18aa6e73e2f6354f7bcb2106ae97c1f0 (patch) | |
tree | c7640a9ae384da3b0179e7f9f5349307ace92cf9 /PKGBUILD | |
parent | e96d64402766e2a4c526a887690b7ebfce86d123 (diff) | |
download | aur-ae89fbcb18aa6e73e2f6354f7bcb2106ae97c1f0.tar.gz |
PKGBUILD improvements
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 7 |
1 files changed, 4 insertions, 3 deletions
@@ -3,14 +3,14 @@ _pkgname=eth-utils pkgname=python-$_pkgname pkgver=1.4.1 -pkgrel=1 +pkgrel=2 pkgdesc="Utility functions for working with Ethereum related codebases." arch=('x86_64') url="https://github.com/ethereum/eth-utils" license=('MIT') depends=('python' 'python-eth-hash' 'python-eth-typing' 'python-toolz') makedepends=('python-setuptools') -source=("https://github.com/ethereum/eth-utils/archive/v${pkgver}.tar.gz") +source=("$pkgname-$pkgver.tar.gz::https://github.com/ethereum/eth-utils/archive/v${pkgver}.tar.gz") sha256sums=('71113fc420bc6c3fbe144f96a7a5298e5d2a9b56ce8b8e563b09f6d7f209bde5') build() { @@ -20,5 +20,6 @@ build() { package() { cd "$srcdir/$_pkgname-$pkgver" - python setup.py install --root=$pkgdir --optimize=1 --skip-build + python setup.py install --root="$pkgdir" --optimize=1 --skip-build + install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}" } |