summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoralgebro2019-01-19 15:17:17 -0500
committeralgebro2019-01-19 15:17:17 -0500
commitae89fbcb18aa6e73e2f6354f7bcb2106ae97c1f0 (patch)
treec7640a9ae384da3b0179e7f9f5349307ace92cf9 /PKGBUILD
parente96d64402766e2a4c526a887690b7ebfce86d123 (diff)
downloadaur-ae89fbcb18aa6e73e2f6354f7bcb2106ae97c1f0.tar.gz
PKGBUILD improvements
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8290ebbf0095..5c0f4d0551e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
_pkgname=eth-utils
pkgname=python-$_pkgname
pkgver=1.4.1
-pkgrel=1
+pkgrel=2
pkgdesc="Utility functions for working with Ethereum related codebases."
arch=('x86_64')
url="https://github.com/ethereum/eth-utils"
license=('MIT')
depends=('python' 'python-eth-hash' 'python-eth-typing' 'python-toolz')
makedepends=('python-setuptools')
-source=("https://github.com/ethereum/eth-utils/archive/v${pkgver}.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/ethereum/eth-utils/archive/v${pkgver}.tar.gz")
sha256sums=('71113fc420bc6c3fbe144f96a7a5298e5d2a9b56ce8b8e563b09f6d7f209bde5')
build() {
@@ -20,5 +20,6 @@ build() {
package() {
cd "$srcdir/$_pkgname-$pkgver"
- python setup.py install --root=$pkgdir --optimize=1 --skip-build
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}