summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristoph Fink2020-04-28 19:44:43 +0300
committerChristoph Fink2020-04-28 19:44:43 +0300
commit940f20f4afbc87cbb6ad1abebbbc279125744ed3 (patch)
tree5f99df29b33a71b89580a1ba4c80a67282fff3d5 /PKGBUILD
parentbe93218d805f016194354a857a8a3b6521e914df (diff)
downloadaur-940f20f4afbc87cbb6ad1abebbbc279125744ed3.tar.gz
v0.9.2-0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 89f6d0e5b79b..d11773d85258 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: peippo <christoph.fink@gmail.com>
+# Maintainer: peippo <christoph+aur@christophfink.com>
pkgname='python-fasttext'
pkgdesc="Library for fast text representation and classification – Python bindings"
@@ -7,17 +7,17 @@ url="https://github.com/facebookresearch/fastText"
provides=('python-fasttext')
conflicts=('python-fasttext')
-pkgver=0.9.1
+pkgver=0.9.2
pkgrel=0
-arch=('any')
+arch=('x86_64')
license=('BSD')
makedepends=('python-setuptools' 'python2-setuptools')
depends=('pybind11' 'python-future' 'python-numpy' 'python-scipy' 'python-pytorch')
-source=("https://github.com/facebookresearch/fastText/archive/v${pkgver}.tar.gz")
-sha256sums=("254ace2fc8dc3bea0fc6ad4897a221eb85c1e9adfa61d130b43398193ca1f061")
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/facebookresearch/fastText/archive/v${pkgver}.tar.gz")
+sha256sums=("7ea4edcdb64bfc6faaaec193ef181bdc108ee62bb6a04e48b2e80b639a99e27e")
build() {
cd "${srcdir}/fastText-${pkgver}"
@@ -27,4 +27,6 @@ build() {
package() {
cd "${srcdir}/fastText-${pkgver}"
python setup.py install --root=${pkgdir} --optimize=1
+
+ install -Dm0644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}