summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWill Handley2017-09-11 18:40:07 +0100
committerWill Handley2017-09-11 18:40:07 +0100
commit03e0ac1c59a1386fc3d08436a42e7847d8f937a9 (patch)
treebc9ad2927e38e3b3546a27ab38055a43d7b3fac8 /PKGBUILD
downloadaur-03e0ac1c59a1386fc3d08436a42e7847d8f937a9.tar.gz
1.0.22
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f8a14b1f91e3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Will Handley <wh260@cam.ac.uk>
+_modulename=fgivenx
+pkgname=python-$_modulename
+pkgver=1.0.22
+pkgrel=1
+pkgdesc="Python library for plotting Bayesian Functional Posteriors."
+arch=(any)
+url="https://github.com/williamjameshandley/fgivenx"
+license=('MIT')
+groups=()
+depends=('python-numpy' 'python-matplotlib' 'python-scipy' 'python-joblib' 'python-mpi4py' 'python-tqdm')
+makedepends=('python-setuptools')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=('https://github.com/williamjameshandley/fgivenx/archive/1.0.22.tar.gz')
+sha256sums=('d674ffaef7e47fd6105a521f2e8f4ee6da61fe8d0bba5d2dd1aeb6739e8fc71a')
+package() {
+ cd "$srcdir/$_modulename-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
+}