summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoreDgar2021-08-31 15:16:57 -0500
committereDgar2021-08-31 15:16:57 -0500
commit45e8d978a12da97482c9acf82ea38ad8e64c755a (patch)
tree835fcd05073475a257ac1406f873c77f101f8d62 /PKGBUILD
parent5081e892be565535e1e35f3c31751383be9949e5 (diff)
downloadaur-45e8d978a12da97482c9acf82ea38ad8e64c755a.tar.gz
pkgver by git tag; _base; gitignore
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 90bc27bf79b4..9389ec757d4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Lucas H. Gabrielli <heitzmann@gmail.com>
-pkgname=python-fiat-git
+_base=fiat
+pkgname=python-${_base}-git
pkgdesc="Generation of arbitrary order Lagrange elements on lines, triangles, and tetrahedra."
-pkgver=20200113
+pkgver=2019.1.0.70.g2f19f48
pkgrel=1
arch=('any')
url="https://bitbucket.org/fenics-project/fiat"
@@ -11,12 +12,12 @@ groups=('fenics-git')
depends=('python-numpy' 'python-sympy')
makedepends=('python-setuptools' 'git')
options=(!emptydirs)
-source=("fiat::git+https://bitbucket.org/fenics-project/fiat.git")
+source=("fiat::git+${url}.git")
md5sums=('SKIP')
pkgver() {
- cd fiat
- git log --format="%cd" --date=short -1 | sed 's/-//g'
+ cd "${srcdir}/${_base}"
+ git describe --tags --match '*.*' | tr '-' '.'
}
build() {