summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilipp A2022-09-16 17:23:22 +0200
committerPhilipp A2022-09-16 17:23:22 +0200
commit23c86bbe1e03a304c45022617640e52c3b2841b7 (patch)
tree4e783d31fdcb226c56dad4f439a6f490b595a9a1 /PKGBUILD
parent0c8ea63fafe39cba469407fc823cdc47218f6438 (diff)
downloadaur-python-fintech.tar.gz
v7.2.6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 920feb0f37de..5ca03048dc2c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,20 @@
_name=fintech
pkgname=python-$_name
-pkgver=6.6.5
+pkgver=7.2.6
pkgrel=1
pkgdesc='Finance tech: SEPA, EBICS & more'
arch=(any)
url="https://www.joonis.de/en/$_name/"
license=('custom:restricted use')
-_pyminor=9
-depends=("python>=3.$_pyminor" "python<3.$((_pyminor + 1))" python-certifi 'python-fpdf>=1.7.2' python-lxml)
-_pyarch=cp3$_pyminor
-_wheel="${_name/-/_}-$pkgver-$_pyarch-none-any.whl"
-source=("https://files.pythonhosted.org/packages/$_pyarch/${_name::1}/$_name/$_wheel")
-sha256sums=('01cdf6e983b335601b53db04d6fd29a95c6906e88c89336fd20fc6985a1a1bdc')
+_pyminor=10
+depends=("python>=3.$_pyminor" "python<3.$((_pyminor + 1))" python-lxml python-cryptography python-certifi 'python-fpdf>=1.7.2' python-defusedxml)
+makedepends=(python-installer)
+_wheel="${_name/-/_}-$pkgver-cp3$_pyminor-none-any.whl"
+source=("https://files.pythonhosted.org/packages/cp3$_pyminor/${_name::1}/$_name/$_wheel")
+sha256sums=('f720f895d91c937f6d0c1d496ef12c357ec9713bad6a1a4f65af66cdee874924')
noextract=("$_wheel")
package() {
- local site="$pkgdir/usr/lib/python3.$_pyminor/site-packages"
- mkdir -p "$site"
- unzip "$_wheel" -d "$site"
+ python -m installer --destdir="$pkgdir" "$_wheel"
}