summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilipp A2019-03-07 14:10:50 +0100
committerPhilipp A2019-03-07 14:10:50 +0100
commitcb6163aca6532bcb861245640d75c351b5925805 (patch)
treee52a465e05306fec3e8a1cac6ddd62d27287fe49 /PKGBUILD
parent016e57a84a0a07ab89f818672326e51572afce05 (diff)
downloadaur-cb6163aca6532bcb861245640d75c351b5925805.tar.gz
v5.2.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1c2049837330..cd909a3997f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,21 @@
_name=fintech
pkgname=python-$_name
-pkgver=5.2.0
+pkgver=5.2.1
pkgrel=1
pkgdesc=''
arch=(any)
url="https://github.com/theislab/$_name"
license=('custom:restricted use')
depends=(python-certifi 'python-fpdf>=1.7.2' python-lxml)
-makedepends=(python-pip)
-_wheel="$_name-$pkgver-cp37-none-any.whl"
-source=("https://files.pythonhosted.org/packages/cp37/${_name::1}/$_name/$_wheel")
-sha256sums=('ff189b7c97f4600d49f25a960e5faf28c3b2dd16efeab494776e2c7a80393e78')
+_pyarch=cp37
+_wheel="${_name/-/_}-$pkgver-$_pyarch-none-any.whl"
+source=("https://files.pythonhosted.org/packages/$_pyarch/${_name::1}/$_name/$_wheel")
+sha256sums=('3239606d6d30fce6b0cac405b2696366d0b57ff5bffb281e7ecaec3fc2004d25')
noextract=("$_wheel")
package() {
- cd "$srcdir"
- pip install --compile --no-deps --ignore-installed --root="$pkgdir" "$_wheel"
+ local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
+ mkdir -p "$site"
+ unzip "$_wheel" -d "$site"
}