summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFelix Yan2019-05-25 08:52:00 +0000
committerFelix Yan2019-05-25 08:52:00 +0000
commit4c4ad66953611ad8b0801b99394bea004140bd05 (patch)
treeab44d44193d75eb29922f14deae0c8a0e00dda29 /PKGBUILD
downloadaur-4c4ad66953611ad8b0801b99394bea004140bd05.tar.gz
addpkg: 2.0.1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b778f534d6ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+
+pkgname=python-first
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="Return the first true value of an iterable"
+url="https://github.com/hynek/first"
+license=('MIT')
+arch=('x86_64')
+depends=('python')
+makedepends=('python-setuptools')
+checkdepends=('python-pytest-runner')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/hynek/first/archive/$pkgver.tar.gz")
+sha512sums=('c0794fa6d6185a12ef51c39a5b659a4f09e22c6d7284a8f6f10a62fe0744e4158ced191dff6f160bffd83043a8bf76948214861e9c2341d5d231f6f9b6af19f4')
+
+build() {
+ cd first-$pkgver
+ python setup.py build
+}
+
+check() {
+ cd first-$pkgver
+ python setup.py pytest
+}
+
+package() {
+ cd first-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1
+
+ install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
+}