summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorandalenavals2017-12-29 01:31:09 -0500
committerandalenavals2017-12-29 01:31:09 -0500
commit4f901916786587a58821de9ecc2c3ff438a36e2d (patch)
tree31ad7684e2a42ee4d3182005860a82f85180c3e2 /PKGBUILD
parent3841ab2c37e0928aac00cbaa311ceccf54da1272 (diff)
downloadaur-4f901916786587a58821de9ecc2c3ff438a36e2d.tar.gz
Correcting pkgver()m the project included tags
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1605bce134ed..86b1155fb2e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: E. Sheldon
pkgname=python-fitsio-git
-pkgver=r640.507ad1c
+pkgver=v0.9.12rc1.r22.507ad1c
pkgrel=1
pkgdesc=" A python library to read from and write to FITS files. "
arch=('i686' 'x86_64')
@@ -16,7 +16,7 @@ source=("${pkgname%-git}::git+${url}")
md5sums=('SKIP')
pkgver() {
cd "$srcdir/${pkgname%-git}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
}
build() {