summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoracxz2020-05-30 18:35:42 -0400
committeracxz2020-05-30 18:35:42 -0400
commitfd4a922b70c41752f30949e0f9e295dbd4146c23 (patch)
tree53ec3ad88d6ec60ef0a2b3a5f7f7475aaf9e01a0 /PKGBUILD
downloadaur-fd4a922b70c41752f30949e0f9e295dbd4146c23.tar.gz
create python-flake8-deprecated
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ec97740e7d3a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: acxz <akashpatel2008@yahoo.com>
+
+pkgname="python-flake8-deprecated"
+_pkgname="flake8-deprecated"
+pkgver=1.3
+pkgrel=1
+pkgdesc="Warns about deprecated method calls."
+arch=('any')
+url="https://github.com/gforcada/${_pkgname}"
+license=('GPL-2.0')
+depends=('flake8')
+source=("https://github.com/gforcada/flake8-deprecated/archive/$pkgver.tar.gz")
+md5sums=('51bb7161af44baf4ef5f1c610e0343b5')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}