summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorpappy2023-12-06 01:39:44 +0200
committerpappy2023-12-06 01:39:44 +0200
commitc040fcbaddad834cd31fe75bc8f7be7ee2e5d144 (patch)
tree27f73c0fdf94383fac20067b9b140b9f2206c3b2 /PKGBUILD
parent9ef72acd973d042b83986d055340960addc083c7 (diff)
downloadaur-python-flask-assets.tar.gz
Upgraded to 2.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 33054de6ddf1..9df0e5603ad7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,24 @@
# Maintainer: pappy <pa314159@users.noreply.github.com>
py_name=flask-assets
pkgname=python-$py_name
-pkgver=2.0
+pkgver=2.1.0
pkgrel=1
pkgdesc="Asset management for Flask, to compress and merge CSS and Javascript files"
arch=(any)
url="https://flask-assets.readthedocs.io"
license=('BSD')
-depends=('python' 'python-flask' 'python-webassets')
-makedepends=('python-distribute')
+depends=(python python-flask python-webassets)
+makedepends=(python-build python-installer python-wheel)
source=("https://github.com/miracle2k/$py_name/archive/refs/tags/$pkgver.tar.gz")
-sha256sums=('a0c6f8c2a2caa0f6b83a5878b594b3a8cbd0b47a45986ab514b8b9ac7d84b568')
+sha256sums=('e6903374cda21d667448233251ec046201e5bc1aa8b26b725e99a633d1f80183')
+
+build() {
+ cd "$srcdir/$py_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
package() {
- cd "$srcdir/$py_name-$pkgver"
- python setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1
+ cd "$srcdir/$py_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}