summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristian Mauderer2018-08-16 18:01:14 +0200
committerChristian Mauderer2018-08-16 18:01:14 +0200
commitc5014f70c711ed61387f6229b68cc60fc0ae2b71 (patch)
treed0e3d08abb9687bac464cd645a893494820aa7dc /PKGBUILD
parent223a50c6d9ac4badfb8e4ddb0935a6396fa8b8f8 (diff)
downloadaur-python-flask-cache.tar.gz
Add workarround for flask.ext problem.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 751e93373cf5..81a4eae66a80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: Justin Dray <justin@dray.be>
+# Maintainer: Christian Mauderer <oss@c-mauderer.de>
+# Previous maintainer: Justin Dray <justin@dray.be>
pkgname='python-flask-cache'
pkgver=0.13.1
-pkgrel=1
+pkgrel=2
pkgdesc='Adds cache support to your Flask application'
arch=('any')
url='http://pypi.python.org/pypi/Flask-Cache'
@@ -16,6 +17,10 @@ conflicts=('python-flask-cache-git')
build() {
cd "${srcdir}/Flask-Cache-${pkgver}"
+
+ # Workaround for https://github.com/thadeusb/flask-cache/issues/188
+ sed -e 's/flask.ext.cache/flask_cache/g' -i flask_cache/jinja2ext.py
+
python ./setup.py build
}