summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJustin Dray2015-05-31 15:02:27 +1000
committerJustin Dray2015-05-31 15:02:27 +1000
commit65ab41a1e10824b93e44d2e2d4150fb93ed28ef0 (patch)
treed65c06860cef1fed11ce7facd134bd3b2b2924b2 /PKGBUILD
downloadaur-65ab41a1e10824b93e44d2e2d4150fb93ed28ef0.tar.gz
Added python-flask-cache
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc0eea213be9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Justin Dray <justin@dray.be>
+
+pkgname='python-flask-cache'
+pkgver=0.13.1
+pkgrel=1
+pkgdesc='Adds cache support to your Flask application'
+arch=('any')
+url='http://pypi.python.org/pypi/Flask-Cache'
+license=('BSD')
+depends=('python-flask')
+makedepends=('python-distribute')
+source=("http://pypi.python.org/packages/source/F/Flask-Cache/Flask-Cache-${pkgver}.tar.gz")
+md5sums=('ab82a9cd0844891ccdb54fbb93fd6c59')
+conflicts=('python-flask-cache-git')
+
+build() {
+
+ cd "${srcdir}/Flask-Cache-${pkgver}"
+ python ./setup.py build
+
+}
+
+package() {
+
+ cd "${srcdir}/Flask-Cache-${pkgver}"
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}