summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGreg Land2020-03-22 18:11:21 -0400
committerGreg Land2020-03-22 18:11:21 -0400
commit371434f176e63f2153d6499753a8e3c34be785b5 (patch)
treed26579cb02a225d1cb6aafd49fb9bef1a33ab58a /PKGBUILD
downloadaur-371434f176e63f2153d6499753a8e3c34be785b5.tar.gz
First version of the package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc7f541173b8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+_name=flask-executor
+pkgname="python-$_name"
+pkgver=0.9.3
+pkgrel=1
+arch=('any')
+pkgdesc="An easy to use Flask wrapper for concurrent.futures"
+url="https://github.com/dchevell/flask-executor"
+license=('MIT')
+#pulling from my personal copy since upstream does not have tags. Bug report submitted for now
+source=("https://github.com/GregoryLand/flask-executor/archive/v"$pkgver".tar.gz")
+sha256sums=('6fc1a0edfd68627aa4d47916324ccbd518ad2302afd4c9e1fe81097e8a7221e6')
+depends=(
+ 'python'
+)
+
+build() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}