summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorZack Buhman2015-09-06 00:37:10 -0500
committerZack Buhman2015-09-06 00:37:10 -0500
commit538027843d58c368e04f1a9142b3e5e5cc01631d (patch)
tree197b031d3bb3e260c9bcf45a891f5f92bbf22b03 /PKGBUILD
downloadaur-538027843d58c368e04f1a9142b3e5e5cc01631d.tar.gz
initial
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5f912d87f63e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+pkgname=python-flask-git
+_pkgname=flask
+pkgver=0.10.1.r682.ge99fec2
+pkgrel=1
+pkgdesc='Micro webdevelopment framework for Python'
+arch=('any')
+url='http://flask.pocoo.org/'
+license=('custom:BSD')
+depends=('python-werkzeug' 'python-jinja' 'python-itsdangerous')
+makedepends=('git')
+conflicts=('python-flask')
+provides=('python-flask')
+source=('git://github.com/mitsuhiko/flask.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $_pkgname
+
+ python setup.py build
+}
+
+package() {
+ cd $_pkgname
+
+ python setup.py install --root=${pkgdir} --optimize=1
+
+ install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/python-flask
+}