summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorredmattski2021-10-13 17:36:40 +0200
committerredmattski2021-10-13 17:36:40 +0200
commitd98c826b5b4341291f488338aa28834dc6ecbb90 (patch)
tree31776070321ccc2cd480bda8a753c1f1018881ff /PKGBUILD
downloadaur-d98c826b5b4341291f488338aa28834dc6ecbb90.tar.gz
initial build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1f6783a5daa8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+pkgbase='python-flask-simpleldap'
+pkgname=('python-flask-simpleldap')
+_module='Flask-SimpleLDAP'
+pkgver='1.4.0'
+pkgrel=1
+pkgdesc="LDAP authentication extension for Flask"
+url="https://github.com/admiralobvious/flask-simpleldap"
+depends=('python')
+makedepends=('python-setuptools')
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
+sha256sums=('812f7a476317e3e4a66549d773d470617e4153f2024fb956872b8f0998765275')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}