summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2016-12-06 19:46:08 +0100
committerMichel Zou2016-12-06 19:46:08 +0100
commitf77aa0a12ae720ff61bd8e1b390e9a139bbddcac (patch)
treefb6ca2d8255d244b023fc39a4d84f80caa1fa41c /PKGBUILD
downloadaur-f77aa0a12ae720ff61bd8e1b390e9a139bbddcac.tar.gz
0.6.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bdeeb76ff4f7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+pkgbase=python-flask-testing
+pkgname=('python-flask-testing' 'python2-flask-testing')
+pkgver=0.6.1
+pkgrel=1
+pkgdesc="Flask unittest integration"
+url="https://github.com/jarus/flask-testing"
+arch=(any)
+license=('BSD')
+makedepends=('python-setuptools' 'python2-setuptools' 'python-flask' 'python2-flask')
+source=("https://github.com/jarus/flask-testing/archive/v${pkgver}.tar.gz")
+md5sums=('bd4513dc0961a46cf28e2f539eb590e1')
+
+prepare() {
+ cd "${srcdir}"/flask-testing-$pkgver
+}
+
+build() {
+ cp -r "${srcdir}"/flask-testing-$pkgver "${srcdir}"/flask-testing-$pkgver-py2
+
+ cd "${srcdir}"/flask-testing-$pkgver
+ python setup.py build
+
+ cd "${srcdir}"/flask-testing-$pkgver-py2
+ python2 setup.py build
+}
+
+package_python-flask-testing() {
+ depends=('python-flask')
+
+ cd "${srcdir}/flask-testing-$pkgver"
+ python setup.py install --root=${pkgdir} --optimize=1
+}
+
+package_python2-flask-testing() {
+ depends=('python2-flask')
+
+ cd "${srcdir}/flask-testing-$pkgver"
+ python2 setup.py install --root=${pkgdir} --optimize=1
+}
+