summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGI_Jack2023-05-13 21:11:28 -0700
committerGI_Jack2023-05-13 21:11:28 -0700
commit21f11e0fa7a0ac3b0f899a97846349bfc4d8947f (patch)
tree0e7e88e4f1b301127e043872e42516f6e55e2316 /PKGBUILD
parent4d17ac09f1e230a7ed95448319bcec350c548bad (diff)
downloadaur-python-flask1.tar.gz
updated for modern packing guidelines
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 7 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 36055f098841..dea5cdf95f0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=python-flask1
pkgver=1.1.4
-pkgrel=2
+pkgrel=3
pkgdesc='Micro webdevelopment framework for Python(1.x Branch)'
url='http://flask.pocoo.org/'
arch=('any')
@@ -15,26 +15,17 @@ license=('custom:BSD')
provides=("python-flask=1.1.4")
conflicts=("python-flask")
depends=('python-werkzeug' 'python-jinja' 'python-itsdangerous' 'python-click')
-makedepends=('python-setuptools' 'python-werkzeug'
- 'python-jinja' 'python-itsdangerous' 'python-click' 'python-pip')
+makedepends=('python-build' 'python-installer' 'python-wheel')
source=("$pkgname-$pkgver.tar.gz::https://github.com/pallets/flask/archive/${pkgver}.tar.gz")
sha512sums=('e7ca33d599c0f7b83542620e827c999124ffe30e31006815b49993a81f9cf0d61dd0433b73f57f922da5aeb76101beccfe63d9a7236e1850e326f838dc1f453f')
-
build() {
- cd "flask-$pkgver"
- python setup.py build
-}
-
-check() {
- cd "flask-$pkgver"
- python setup.py test
+ cd "flask-$pkgver"
+ python -m build --wheel --no-isolation
}
package() {
- cd "flask-$pkgver"
-
- python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
- install -Dm644 LICENSE.rst "$pkgdir/usr/share/licenses/$pkgname/LICENSE.rst"
+ cd "flask-$pkgver"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm644 LICENSE.rst "$pkgdir/usr/share/licenses/$pkgname/LICENSE.rst"
}
-