summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorZ.Wind.L2018-08-01 13:43:22 +0800
committerZ.Wind.L2018-08-01 13:43:22 +0800
commitfc21cdac24eb9dd2ecc315a41290b865aa3406d6 (patch)
tree98d5f87d14b745aa7ef04e4c86e8ba51e703daa7 /PKGBUILD
downloadaur-fc21cdac24eb9dd2ecc315a41290b865aa3406d6.tar.gz
dependent for python-gdbgui
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..85b38b9b3490
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+pkgbase=('python-flask12')
+pkgname=('python-flask12')
+_module='Flask'
+pkgver='0.12.4'
+pkgrel=1
+pkgdesc=" The Python micro framework for building web applications"
+url="https://github.com/pallets/flask"
+depends=('python' 'python-werkzeug' 'python-jinja' 'python-itsdangerous' 'python-click')
+makedepends=('python-setuptools')
+provides=('python-flask')
+conflicts=('python-flask')
+license=('MIT')
+arch=('any')
+source=("https://github.com/pallets/flask/releases/download/0.12.4/Flask-0.12.4.tar.gz")
+md5sums=('f885afe6dd25e8d48d5ba23f2857687e')
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}