summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bershatsky2023-02-20 16:08:49 +0300
committerDaniel Bershatsky2023-02-20 16:08:49 +0300
commita70aaef6c96ef56be6ab747afe1dfffb3b8232a1 (patch)
tree3bcbf56ce5f9a6b724a410b3ed1e8d76fccca81c /PKGBUILD
parent8b71fcf00ee5a951f8ab417fae1f197a14afe8df (diff)
downloadaur-a70aaef6c96ef56be6ab747afe1dfffb3b8232a1.tar.gz
Bump version to 0.6.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 23 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 01391c3d6feb..0c79e0ac52d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,31 @@
# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
pkgname=python-flax
_name=${pkgname#python-}
-pkgver=0.6.3
+pkgver=0.6.5
pkgrel=1
-pkgdesc="A neural network library and ecosystem for JAX designed for flexibility"
-arch=(any)
-url="https://github.com/google/flax"
+pkgdesc='A neural network library and ecosystem for JAX designed for flexibility'
+arch=('any')
+url='https://github.com/google/flax'
license=('Apache')
-groups=()
-depends=(python-jax)
-makedepends=(python-build python-installer)
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=(!emptydirs)
-install=
+groups=('jax')
+depends=(
+ 'python-jax'
+ 'python-matplotlib'
+ 'python-msgpack'
+ 'python-numpy'
+ 'python-optax'
+ 'python-pyyaml'
+ 'python-rich'
+ 'python-tensorstore'
+ 'python-typing_extensions'
+)
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+optdepends=(
+ 'python-orbax: Checkpointing routines for JAX.'
+ 'tensorboard: TensorBoard visualization and logging.'
+)
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=(064f33f24f49ecef01c171cc770d22493fb8f9a36ed29db5e75f82d2052682a9)
+sha256sums=('12b921fe16198767d0b662a55024b698f6670b311463fa09d39194661fed1b24')
build() {
cd "$srcdir/$_name-$pkgver"
@@ -26,6 +34,6 @@ build() {
package() {
cd "$srcdir/$_name-$pkgver"
- python -m installer --destdir="$pkgdir" dist/*.whl
+ python -m installer --compile-bytecode 1 --destdir="$pkgdir" dist/*.whl
}