summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2023-02-23 13:50:52 +0300
committerCaleb Maclennan2023-02-23 13:50:52 +0300
commitb6f6bf5a0260007a832c4cba242725644e269e0e (patch)
tree8b8727075903b7ea5b4b226f6abf72c8730d8c7d /PKGBUILD
parent067beda8cd4f8d2d6bb34637c292150c68b67198 (diff)
downloadaur-python-fontpens.tar.gz
upgpkg: python-fontpens 0.2.4-4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d33520ed3097..070afd686044 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,13 +9,14 @@ BUILDENV+=(!check)
_pyname=fontPens
pkgname=python-${_pyname,,}
pkgver=0.2.4
-pkgrel=3
-pkgdesc='A collection of classes implementing the pen protocol for manipulating glyphs.'
+pkgrel=4
+pkgdesc='A collection of classes implementing the pen protocol for manipulating glyphs'
arch=(any)
-url='https://github.com/robotools/$_pyname'
+url="https://github.com/robotools/$_pyname"
license=(BSD)
depends=(python-fonttools)
-makedepends=(python-setuptools)
+makedepends=(python-{build,installer,wheel}
+ python-setuptools)
checkdepends=(python-fontparts
python-pytest)
_archive="$_pyname-$pkgver"
@@ -24,7 +25,7 @@ sha256sums=('a6d9a14573b3450f3313d69523f9006028c21fc7aef5d35333b87aab7f2b41fd')
build() {
cd "$_archive"
- python setup.py build
+ python -m build -wn
}
check() {
@@ -34,7 +35,7 @@ check() {
package() {
cd "$_archive"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer -d "$pkgdir" dist/*.whl
install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE.txt
}