summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Icenhour2021-02-06 16:29:55 -0600
committerChris Icenhour2021-02-06 16:29:55 -0600
commit0233fa1c8857ed94c469c00654b79ce534820956 (patch)
tree25602a738002761904fae7679db01eb3bc69c0ce /PKGBUILD
parent461c20fb58ebe7824246cc7f31540adc7e016447 (diff)
downloadaur-0233fa1c8857ed94c469c00654b79ce534820956.tar.gz
switch to develop branch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3c08997511e9..684b13cdc5e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chris Icenhour <chris@randomlinux.com>
pkgname=python-freqtrade-git
-pkgver=2021.1.r0.g766c786d
+pkgver=0.14.3.r10448.g4cb67f14
pkgrel=1
pkgdesc="Free, open source crypto trading bot"
url="https://github.com/freqtrade/freqtrade"
@@ -19,15 +19,12 @@ depends=('python-sqlalchemy' 'python-cachetools'
'python-hyperopt' 'python-coinmarketcap' 'python-ccxt' 'python-certifi' 'python-aiohttp'
'python-pytables' )
-_branch="stable"
-source=("$pkgname"::"git://github.com/freqtrade/freqtrade.git#branch=${_branch}")
+source=("$pkgname"::"git://github.com/freqtrade/freqtrade.git#branch=develop")
sha256sums=('SKIP')
pkgver() {
cd "$pkgname"
- version=$(git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g')
- sed -i "s/^__version__.*$/__version__ = '$version'/g" freqtrade/__init__.py
- echo $version
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {