summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorslackk2020-03-17 10:06:35 -0400
committerslackk2020-03-17 10:06:35 -0400
commit87508c4082ebf09234c72e5014c01036a1ed6a26 (patch)
treea6b1d084e6031d00a76108897063078a91ae554b /PKGBUILD
parent9d32827e15ad08f1b8f5c52af085650354f2a0cf (diff)
downloadaur-87508c4082ebf09234c72e5014c01036a1ed6a26.tar.gz
added new dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3bbcc05594ff..0dffa9d0d998 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,8 @@ depends=('python-sqlalchemy' 'python-cachetools'
'python-scipy' 'python-jsonschema' 'python-numpy' 'python-pytest'
'python-pytest-mock' 'python-pytest-cov' 'python-networkx'
'python-telegram-bot' 'python-tabulate' 'python-hyperopt' 'python-ta-lib'
- 'python-bittrex' 'python-questionary' 'python-jinja' 'python-sdnotify' 'python-rapidjson')
+ 'python-bittrex' 'python-questionary' 'python-jinja' 'python-sdnotify' 'python-rapidjson'
+'python-hyperopt' 'python-coinmarketcap' 'python-ccxt')
_branch="master"
source=("$pkgname"::"git://github.com/gcarq/freqtrade.git#branch=${_branch}")
@@ -29,9 +30,6 @@ pkgver() {
package() {
cd "$srcdir/$pkgname"
pip install --prefix=/usr --root="hyperopt" hyperopt
- pip install --prefix=/usr --root="py-find-1st" py-find-1st
- pip install --prefix=/usr --root='coinmarketcap' coinmarketcap
- pip install --prefix=/usr --root='ccxt' ccxt
python setup.py build
python setup.py install --prefix=/usr --root="$pkgdir"