summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoralgebro2018-11-13 12:52:30 -0500
committeralgebro2018-11-13 13:00:16 -0500
commit626c3f4629a4bb974d8e66a5b4d3b9e7bae6a276 (patch)
tree8451990a71e51a8f90e0e9c0f4bbd04d13d5e77b /PKGBUILD
downloadaur-626c3f4629a4bb974d8e66a5b4d3b9e7bae6a276.tar.gz
Initial commit
Add license
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..08c511b67d8a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: algebro <algebro at tuta dot io>
+
+_pkgname=frida-tools
+pkgname=python-$_pkgname
+pkgver=1.2.2
+pkgrel=1
+pkgdesc="Inject JavaScript to explore native apps on Windows, Mac, Linux, iOS and Android. Python 3 version from PyPi."
+arch=('i686' 'x86_64')
+url="http://www.frida.re"
+license=('wxWindows Library License, Version 3.1')
+depends=('python' 'python-pygments>=2.02' 'python-prompt_toolkit=1.0.15' 'python-colorama>=0.2.7' 'python-frida>=12.1.0')
+source=("https://files.pythonhosted.org/packages/source/f/${_pkgname}/${_pkgname}-${pkgver}.tar.gz"
+ "COPYING")
+sha256sums=('d059760a06a4b01738685973502ea0655f1a49cc50305573c3264f06c1683942'
+ '5ea1544b51a28bc823b03159190d4108f9fb4f4ef912389f5137c6d295e175b2')
+conflicts=("python2-${_pkgname}")
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root=$pkgdir --optimize=1 --skip-build
+ cd "$srcdir"
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ install -m 644 "COPYING" "$pkgdir/usr/share/licenses/$pkgname/"
+}