summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorandalenavals2017-12-30 19:17:46 -0500
committerandalenavals2017-12-30 19:17:46 -0500
commitbddc3917be95fd5c780c9a1dcf0ea3a8f2532c09 (patch)
tree1626c95399e8ed917bb63b11074dab16773a4ec5 /PKGBUILD
downloadaur-bddc3917be95fd5c780c9a1dcf0ea3a8f2532c09.tar.gz
without test of lsst stack
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4c00d535271a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Andres Alejandro Navarro Alsina <aanavarroa@unal.edu.co>
+# Contributor: GalSim developers team on GitHub
+_pkgname=python-galsim
+pkgname=${_pkgname}-git
+pkgver=v1.5.1.r0.9de448ef9
+pkgrel=1
+pkgdesc=" The modular galaxy image simulation toolkit "
+arch=('i686' 'x86_64')
+url="https://github.com/GalSim-developers/GalSim.git"
+license=('BSD')
+depends=('python' 'boost-libs' 'fftw' 'tmv-git')
+makedepends=('git' 'scons' )
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${_pkgname}::git+${url}")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd "${_pkgname}"
+ scons PREFIX=/usr TMV_DIR=/usr PYTHON=python
+}
+
+package() {
+ cd "${_pkgname}"
+ scons PREFIX=$pkgdir/usr FINAL_PREFIX=/usr install
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}