summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoractionless2020-03-30 11:38:56 +0200
committeractionless2020-03-30 11:38:56 +0200
commit293450a03aec53040399ffc3d08fd2afc030b21d (patch)
treea436300006d3f397d4a34907bc2ef2a39c2679e7 /PKGBUILD
downloadaur-293450a03aec53040399ffc3d08fd2afc030b21d.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eff3defd6078
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Yauhen Kirylau <actionless DOT loveless PLUS aur AT gmail MF com>
+
+_name=gaphor
+pkgname=python-${_name}
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="Simple and easy to use modeling tool for UML using GTK3"
+arch=('any')
+url="https://github.com/gaphor/${_name}"
+license=('Apache')
+depends=(
+ 'python-gaphas'
+ 'python-typing_extensions'
+ 'python-generic'
+)
+makedepends=('python-pip')
+_wheelname="${_name/-/_}-$pkgver-py3-none-any.whl"
+source=("https://files.pythonhosted.org/packages/py3/${_name::1}/$_name/${_wheelname}")
+sha256sums=('9917a41ff4b0aa70fd2f742906d08cd6684b48d6827eca41faede23757ae6339')
+
+package() {
+ PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps "${_wheelname}"
+}
+