summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDanct122021-09-12 10:31:20 +0700
committerDanct122021-09-12 10:31:20 +0700
commitf2e23f5e143ff2a49a103573af76ea655385f641 (patch)
tree3109f6652b3b2a5210c0f41f80ae757a9194526d /PKGBUILD
downloadaur-f2e23f5e143ff2a49a103573af76ea655385f641.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..abe604f7790f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Danct12 <danct12@disroot.org>
+
+pkgname=python-gbinder
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Python bindings for libgbinder"
+arch=('x86_64' 'i686' 'armv7h' 'aarch64')
+url="https://github.com/erfanoabdi/gbinder-python"
+license=('GPL')
+depends=('libgbinder')
+makedepends=('git' 'python-setuptools' 'cython')
+_commit="2e1e05c0a0240d6c06e9bbe9b22dcc35c2e0211c"
+source=(${pkgname}::git+https://github.com/erfanoabdi/gbinder-python.git#commit=${_commit})
+sha512sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ git describe --tags | sed 's/^v//;s/-/+/g'
+}
+
+build() {
+ cd ${pkgname}
+ python3 setup.py build --cython
+}
+
+package() {
+ cd ${pkgname}
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}