summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPatrick Griffis2016-12-23 06:03:45 -0500
committerPatrick Griffis2016-12-23 06:03:45 -0500
commitef575921b1c51ec63d0af7c1e7a8d039bad4714c (patch)
tree0d0484e51f62c29f14fd7dc402940326f76437ac /PKGBUILD
parent3a757a7e74afa53979b71b2d9de596eadf62fd5e (diff)
downloadaur-ef575921b1c51ec63d0af7c1e7a8d039bad4714c.tar.gz
Run tests
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 7 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aa3638b6466d..2bac9625412a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,9 +11,16 @@ license=('Apache')
makedepends=('python-setuptools')
depends=('python-gobject')
optdepends=('gtk3: Gtk application integration')
+checkdepends=('python-pytest')
source=("https://github.com/nathan-hoad/gbulb/archive/$pkgver.tar.gz")
sha256sums=('91b60a05da3197e537525224f88ba23d951b9175a6a33d6d4565e492ab591c35')
+check() {
+ cd "$_modname-$pkgver"
+
+ pytest
+}
+
package() {
cd "$_modname-$pkgver"