summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGrafcube2023-10-21 10:38:06 +0530
committerGrafcube2023-10-21 10:38:26 +0530
commitfd01391c84ea9525d73ca96e7d8767f0e5881b02 (patch)
treeb4d1259225c0df97ad3099eec2af0367217b12fa /PKGBUILD
parent0b3514bb765a2ffff2d169a622d2c4b43cf69442 (diff)
downloadaur-fd01391c84ea9525d73ca96e7d8767f0e5881b02.tar.gz
Fix lark parser dependency
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 15 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b2bc767cc0fe..e88af426c8a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,27 @@
# Maintainer: Grafcube <grafcube at disroot dot org>
+_lark_whl=lark-1.1.5-py3-none-any.whl
+
_pkgname=gdtoolkit
pkgname=python-${_pkgname}
pkgver=4.1.0
-pkgrel=1
+pkgrel=2
pkgdesc='Independent set of tools for working with GDScript - parser, linter and formatter'
arch=(any)
url='https://github.com/Scony/godot-gdscript-toolkit'
license=(MIT)
-depends=(python python-setuptools python-docopt-ng python-lark-parser python-yaml python-radon python-regex python-six)
-makedepends=()
+depends=(python python-setuptools python-docopt-ng python-yaml python-radon python-regex python-six)
+makedepends=(python-installer)
provides=()
-conflicts=()
-source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
-sha256sums=('398d0c7a1d0b8c01150f31430780d7074cac34ef4292b36ac6814c7c04edc909')
+conflicts=(python-lark-parser)
+source=(
+ "https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+ "https://files.pythonhosted.org/packages/py3/l/lark/${_lark_whl}"
+)
+sha256sums=(
+ '398d0c7a1d0b8c01150f31430780d7074cac34ef4292b36ac6814c7c04edc909'
+ '8476f9903e93fbde4f6c327f74d79e9b4bd0ed9294c5dfa3164ab8c581b5de2a'
+)
build() {
cd "$_pkgname-$pkgver"
@@ -21,6 +29,7 @@ build() {
}
package() {
+ python -m installer --destdir="$pkgdir" $_lark_whl
cd "$_pkgname-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"