summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLucki2020-06-19 19:54:23 +0200
committerLucki2020-06-19 19:54:23 +0200
commitcbc6e3c195de5334a669afe7e3c4aa0f5eb09503 (patch)
tree97b0928aaab0b167da1d7247805eddd99355d068 /PKGBUILD
downloadaur-python-genzshcomp.tar.gz
Initial upload: python-genzshcomp 0.6.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..acb05cd8024f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Lucki <https://aur.archlinux.org/account/Lucki>
+# shellcheck disable=SC2034,2154,2148
+
+pkgname=python-genzshcomp
+_pkgname=${pkgname#python-}
+pkgver=0.6.0
+pkgrel=1
+source=("$pkgname-$pkgver.src.tar.gz::https://github.com/hhatto/$_pkgname/archive/$pkgver.tar.gz")
+sha512sums=('21997c8e0e5de263a797dc195b2aa8fbdd8adc64a8c474260e654de1e03cbfa8c53bb6d58e5eefb40f58903ae1fa939f89398c243f20428504f273a150db2e66')
+pkgdesc="Automatic generate to Zsh Completion Function from Python's Option Parser Modules."
+arch=('any')
+url="https://github.com/hhatto/genzshcomp"
+license=('BSD3')
+depends=('python')
+makedepends=('python-setuptools')
+
+build() {
+ cd "$_pkgname-$pkgver" || exit
+ python setup.py build
+}
+
+package() {
+ cd "$_pkgname-$pkgver" || exit
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}