summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander Fasching2021-08-06 11:17:13 +0200
committerAlexander Fasching2021-08-06 11:17:13 +0200
commit9b748dad94dad7bad981bb3039c46775d6f814fa (patch)
tree54bac0ffbce73860541416a279aeb75e716b50bb /PKGBUILD
parent4f4b6994c5fd4f89533f3998d770200abd9ec5a2 (diff)
downloadaur-python-geojson.tar.gz
upgpkg: python-geojson 2.5.0-2
Patch for Python 3.9 support
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 30eab68f6991..a090ce1af8b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,22 @@
# Contributor: Johannes Loethberg <johannes@kyriasis.com>
pkgname=python-geojson
pkgver=2.5.0
-pkgrel=1
+pkgrel=2
pkgdesc="Python bindings and utilities for GeoJSON"
url="https://github.com/frewsxcv/python-geojson"
arch=('any')
license=('BSD')
depends=('python')
makedepends=('python-setuptools')
-source=(python-geojson-$pkgver.tar.gz::https://github.com/frewsxcv/python-geojson/archive/$pkgver.tar.gz)
-sha1sums=('e24040ec8efc582d2d3ef71b4e922ab5fe3b2bdd')
+source=(python-geojson-$pkgver.tar.gz::https://github.com/frewsxcv/python-geojson/archive/$pkgver.tar.gz
+ 0001-Remove-encoding-parameter-from-json.load-for-Python-.patch)
+sha1sums=('e24040ec8efc582d2d3ef71b4e922ab5fe3b2bdd'
+ 'fcb3e74597fe4858c95ab63c2d38b04f27e80516')
+
+prepare() {
+ cd geojson-$pkgver
+ patch -p1 < "${srcdir}"/0001-Remove-encoding-parameter-from-json.load-for-Python-.patch
+}
build() {
cd geojson-$pkgver