summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGuillaume Horel2017-09-05 15:44:08 -0400
committerGuillaume Horel2017-09-05 15:46:48 -0400
commit924d9c9abb6e233a96ff2ba2ed3830db67ecd9f1 (patch)
treea503e560ccbe505e4a1db8d959f9fc84379b6684 /PKGBUILD
parenta9ddd9e6f6bfb92619fe8252ca0a04fb2656b820 (diff)
downloadaur-924d9c9abb6e233a96ff2ba2ed3830db67ecd9f1.tar.gz
version bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7a1837fb2c65..2908a0131ecb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,27 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
pkgname=python-geopandas
_pkgname=geopandas
-pkgver=0.2.1
+pkgver=0.3.0
pkgrel=1
pkgdesc="Geographic pandas extension"
arch=('any')
url="https://github.com/geopandas/geopandas"
license=('BSD')
-checkdepends=('python-nose' 'python-descartes')
-depends=('python' 'python-numpy' 'python-pandas' 'python-shapely' 'python-fiona' 'python-six' 'python-pyproj')
-optdepends=('python-geopy' 'python-psycopg2' 'python-descartes' 'python-rtree')
+checkdepends=('python-descartes' 'python-matplotlib' 'python-pytest' 'python-rtree')
+depends=('python' 'python-fiona' 'python-numpy' 'python-pandas' 'python-pyproj' 'python-shapely' 'python-six')
+optdepends=('python-descartes' 'python-geopy' 'python-psycopg2')
options=(!emptydirs)
source=("https://github.com/geopandas/geopandas/archive/v$pkgver.tar.gz")
-sha256sums=('1e1845acbf6cf8dd2850aec9bfaa92892e462887903e3ea1abb8111e88a41206')
+sha256sums=('ef49a5c8c2e6ff6ff43a494280d0749fdecdf65f4031624d1639fe238b551804')
prepare() {
cd "$srcdir/$_pkgname-$pkgver"
}
-#check() {
-# cd "$srcdir/$_pkgname-$pkgver"
-# nosetests
-#}
+check() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ pytest
+}
package() {
cd "$srcdir/$_pkgname-$pkgver"