summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorprcastro2016-03-18 09:44:41 -0300
committerprcastro2016-03-18 09:44:41 -0300
commit9efa8b86e4d07e3ca632fddfc19f1b04e5a2fd03 (patch)
treec23cddb1f32ac5c1ee1b133103945a0b726e430a /PKGBUILD
downloadaur-9efa8b86e4d07e3ca632fddfc19f1b04e5a2fd03.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..10500b2967c5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Paulo Castro <p.oliveira.castro@gmail.com>
+pkgname=python-geopandas
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="Geographic pandas extension"
+arch=('any')
+url="https://github.com/geopandas/geopandas"
+license=('BSD')
+depends=('python' 'python-numpy' 'python-pandas' 'python-shapely' 'python-fiona' 'python-six' 'python-pyproj')
+optdepends=('python-geopy' 'python-psycopg2')
+options=(!emptydirs)
+source=("https://pypi.python.org/packages/source/g/geopandas/geopandas-0.1.1.tar.gz")
+md5sums=('a01b5d3eb6bc097665a0ba297c39029f')
+
+package() {
+ cd "$srcdir/geopandas-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}