summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWill Handley2022-03-22 09:21:04 +0000
committerWill Handley2022-03-22 09:21:04 +0000
commit743aad056d10f55b8d031b96d71c35ce75998903 (patch)
tree39b03ed69fcbec845c67e1ee5834c78a5d623d42 /PKGBUILD
parent46e766af73c2567e098a7ae418e273b623b4a6ca (diff)
downloadaur-743aad056d10f55b8d031b96d71c35ce75998903.tar.gz
1.3.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 14 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2b89a5f7bce6..30151fe7ad3b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,30 @@
# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
-_modulename=getdist
-pkgname=python-$_modulename
-pkgver=1.3.3
+pkgname=python-getdist
+_name=GetDist
+pkgver=1.3.4
pkgrel=1
pkgdesc="MCMC sample analysis, kernel densities, plotting, and GUI"
arch=(any)
-url="https://github.com/cmbant/getdist"
+url="https://github.com/cmbant/$_name"
license=()
groups=()
-depends=('python-numpy' 'python-matplotlib' 'python-six' 'python-scipy' 'python-pyside2' 'python-pandas')
-makedepends=('python-setuptools')
+depends=(python-numpy python-matplotlib python-six python-scipy pyside2 python-pandas)
+makedepends=(python-setuptools)
provides=()
conflicts=()
replaces=()
backup=()
options=(!emptydirs)
install=
-source=("${url}/archive/${pkgver}.tar.gz")
-sha256sums=('6c3a28850c0c4c320928724f1a75066dcac5266b6192e5cf55b7f874d0413d42')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('bc007b91fb3cbb0947ef4b6558cbb21a20038b31361a43751f70794c1c6e0721')
+
build() {
- cd "$srcdir/$_modulename-$pkgver/"
- python setup.py build
+ cd "$srcdir/$_name-$pkgver"
+ python -m build --wheel --no-isolation
}
+
package() {
- cd "$srcdir/$_modulename-$pkgver/"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ cd "$srcdir/$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}