summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWill Handley2017-11-02 21:46:14 +0000
committerWill Handley2017-11-02 21:46:14 +0000
commite48c9b0c9da372fa565b5eee591dbeb029410525 (patch)
tree78222c74674f978c137d35ccd4292b9ebe06bee1 /PKGBUILD
downloadaur-e48c9b0c9da372fa565b5eee591dbeb029410525.tar.gz
Added src
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b836d64513c8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
+_pkgname=getdist
+pkgname=python-$_pkgname-git
+pkgver=r112.de5e238
+pkgrel=1
+pkgdesc="MCMC sample analysis, kernel densities, plotting, and GUI"
+arch=('any')
+url="https://github.com/cmbant/getdist"
+license=()
+groups=()
+depends=('python-numpy' 'python-matplotlib' 'python-six' 'python-scipy' 'python-pyside' 'python-pandas')
+makedepends=('git' 'python-setuptools')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=
+source=("${pkgname%-git}::git+$url.git")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}