summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGuillaume Horel2020-04-25 20:38:30 -0400
committerGuillaume Horel2020-04-25 20:38:30 -0400
commit68b53391720e6b22bdcc215658bb1fa7002b971d (patch)
treef6685d6c1ac8ac890d469b3d3cce8eb53152adf6 /PKGBUILD
parent2ad466cd337a9e7aa05ea30f222cc3ec2cc1df03 (diff)
downloadaur-python-glmnet.tar.gz
version bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 12 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aebe7c0ea9d4..48ae07b0cd29 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
-pkgname=('python-glmnet')
-pkgver=2.0.0
+pkgname='python-glmnet'
+pkgver=2.1.1
pkgrel=1
-pkgdesc="A Python port of the glmnet package."
+pkgdesc="A Python port of the glmnet package"
url="https://github.com/civisanalytics/python-glmnet"
makedepends=(
'gcc-fortran'
'python'
'python-numpy')
+checkdepends=('python-pytest')
license=('GPL2' 'BSD')
-arch=('i686' 'x86_64')
+arch=('x86_64')
source=("https://github.com/civisanalytics/python-glmnet/archive/v$pkgver.tar.gz")
-sha256sums=('49a4f9e8cba978ea8f482ef70ca5dff6a3617ef8a9ceae139533251370ac9ded')
+sha256sums=('3516950c7c15496b94951c8ede61b55f304844d9957f68345112262fd2a5f28e')
build() {
export LDFLAGS="$LDFLAGS -shared"
@@ -23,3 +24,9 @@ package() {
cd "${srcdir}/${pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}
+
+check() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py build_ext --inplace
+ PYTHONPATH=. pytest
+}