summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGuillaume Horel2017-03-03 17:56:12 -0500
committerGuillaume Horel2017-03-03 17:56:12 -0500
commit2ad466cd337a9e7aa05ea30f222cc3ec2cc1df03 (patch)
treece924139bc8695fc1fc296927d66201f14789473 /PKGBUILD
parentdcae1276eccc66e9a5704bc8530882b433334c2d (diff)
downloadaur-2ad466cd337a9e7aa05ea30f222cc3ec2cc1df03.tar.gz
version bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 5 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 649106263063..aebe7c0ea9d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
pkgname=('python-glmnet')
-pkgver=1.0.0.r18.g1e63abd
+pkgver=2.0.0
pkgrel=1
pkgdesc="A Python port of the glmnet package."
url="https://github.com/civisanalytics/python-glmnet"
@@ -10,21 +10,16 @@ makedepends=(
'python-numpy')
license=('GPL2' 'BSD')
arch=('i686' 'x86_64')
-source=("git+https://github.com/civisanalytics/python-glmnet.git")
-sha256sums=('SKIP')
-
-pkgver() {
- cd "$pkgname"
- git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
-}
+source=("https://github.com/civisanalytics/python-glmnet/archive/v$pkgver.tar.gz")
+sha256sums=('49a4f9e8cba978ea8f482ef70ca5dff6a3617ef8a9ceae139533251370ac9ded')
build() {
export LDFLAGS="$LDFLAGS -shared"
- cd "${srcdir}/${pkgname}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
python setup.py build
}
package() {
- cd "${srcdir}/${pkgname}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}