summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlilac2019-07-05 05:27:22 +0800
committerlilac2019-07-05 05:27:22 +0800
commit8a32aeeb8e1c89b995a9531b48e92eb1d332f105 (patch)
treeb864d39c34449a4d272d0532e1a152d576924add /PKGBUILD
parent579edfed4ddd6637a0d368c3d79ee7a3491cb7bd (diff)
downloadaur-8a32aeeb8e1c89b995a9531b48e92eb1d332f105.tar.gz
update by lilac
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9a2cac229f5f..0ccc582a9045 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,18 @@
_pkgname=gluon-cv
pkgname=python-gluoncv
pkgver=0.4.0
-pkgrel=1
+pkgrel=2
pkgdesc='A Deep Learning Toolkit for Computer Vision'
arch=(any)
-url=https://gluon-cv.mxnet.io
+url='https://gluon-cv.mxnet.io'
license=('Apache')
-depends=(mxnet python-matplotlib python-numpy python-scipy)
+depends=(
+ 'mxnet'
+ 'python-matplotlib'
+ 'python-numpy'
+ 'python-scipy'
+)
makedepends=(python-setuptools)
-checkdepends=(python-nose python-pytest python-scipy)
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/dmlc/gluon-cv/archive/v${pkgver}.tar.gz")
sha512sums=('4ed486237c86a1b4b4aefee655af32e0dc81c10d421b7fbdd0d57bfbbcaa4ebf9f23b4a763afb087f73853f637c4b01acebcff81b765dd55136fe39a59f7a223')
@@ -19,13 +23,12 @@ build() {
python setup.py build
}
-check() {
- cd "${_pkgname}-${pkgver}"
- pytest -v
-}
-
package() {
cd "${_pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ # install missing json files
+ find "${srcdir}/${_pkgname}-${pkgver}/gluoncv/model_zoo/pruned_resnet" -type f -name "*.json" -exec install -Dm644 {} -t "${pkgdir}/usr/lib/python3.7/site-packages/gluoncv/model_zoo/pruned_resnet" \;
+ find "${srcdir}/${_pkgname}-${pkgver}/gluoncv/model_zoo/quantized" -type f -name "*.json" -exec install -Dm644 {} "${pkgdir}/usr/lib/python3.7/site-packages/gluoncv/model_zoo/quantized" \;
install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
+# vim:set ts=2 sw=2 et: