summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2022-02-15 16:26:09 +0300
committerCaleb Maclennan2022-02-15 16:26:09 +0300
commit6e5e1f8983f11dcdb9fb25ddf00d20b5a0d2bce9 (patch)
tree36db4bd55ef20c414e401099f8cba89506bd14dd /PKGBUILD
downloadaur-6e5e1f8983f11dcdb9fb25ddf00d20b5a0d2bce9.tar.gz
Initial upload: python-glyphsets 0.2.1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c64b46aea4a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+_pyname=glyphsets
+pkgname=python-${_pyname,,}
+pkgver=0.2.1
+pkgrel=1
+pkgdesc='an API with data about glyph sets for many different scripts and languages'
+arch=(any)
+url="https://github.com/googlefonts/$_pyname"
+license=(Apache)
+_pydeps=(fonttools)
+depends=(python
+ "${_pydeps[@]/#/python-}")
+makedepends=(python-setuptools)
+_archive="$_pyname-$pkgver"
+source=("$url/archive/v$pkgver/$_archive.tar.gz")
+sha256sums=('dab3c915f1137eb5a16ea22b679b9e1408d1184134946b1905d90268fe46fe82')
+
+prepare() {
+ cd "$_archive"
+ # Upstream requires outdated setuptools_scm, work around
+ sed -i -e '/_scm/d' setup.py
+ echo "version = '$pkgver'" > Lib/glyphsets/_version
+}
+
+build() {
+ cd "$_archive"
+ python setup.py build
+}
+
+package() {
+ cd "$_archive"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}