summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoriamawacko2024-06-15 19:24:10 -0700
committeriamawacko2024-06-15 19:24:10 -0700
commit63a73e2b2deda6ca883027e7cb0072492b6f2a92 (patch)
tree1057f8587098bb5cfbf2d02e89792a9da3777037 /PKGBUILD
downloadaur-63a73e2b2deda6ca883027e7cb0072492b6f2a92.tar.gz
feat: initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e85931de3cbc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: iamawacko <iamawacko@protonmail.com>
+pkgname=python-gnureadline
+pkgver=8.2.10
+pkgrel=1
+pkgdesc="The standard Python readline extension statically linked against the GNU readline library."
+url="https://pypi.org/project/gnureadline/"
+arch=('any')
+license=('GPL-3.0-or-later')
+_name="gnureadline"
+makedepends=(python-build python-installer python-wheel)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/gnureadline/gnureadline-$pkgver.tar.gz")
+sha256sums=('a746ba98d4de37b079e42d949b704c33c168b30bd1f9071a1d25c9da9a449997')
+
+build() {
+ cd $_name-$pkgver
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd $_name-$pkgver
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}