summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBaltazár Radics2021-11-22 22:18:25 +0100
committerBaltazár Radics2021-11-22 22:18:25 +0100
commit40cfd21eef59f09b6035fb893d3b58c0683adf4e (patch)
tree1442a97e518c198242878bc48d5b31146775d0f2 /PKGBUILD
downloadaur-40cfd21eef59f09b6035fb893d3b58c0683adf4e.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b07a913ebd8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Baltazár Radics <baltazar.radics@gmail.com>
+_name=godirect
+pkgname=python-$_name
+pkgver=1.1.2
+pkgrel=1
+pkgdesc='Library to interface with GoDirect devices via USB and BLE'
+arch=(any)
+url='https://pypi.org/project/godirect'
+license=(GPL)
+depends=(python-hidapi python-bleak)
+makedepends=(python-setuptools)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('6f91ab46944857fdb93e9d1444bb6f1b77b8e0d122f551f686a43573dbe9299e')
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}