summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAinola2018-11-05 19:33:48 -0700
committerAinola2018-11-05 19:33:48 -0700
commit454edb35fdabb417980420963443bff2c1c678a2 (patch)
tree713dfbfc366213669c6fa17c7132441b01cd1458 /PKGBUILD
parent708814a9d7632bc326b264aaffee12b9e8a8e3aa (diff)
downloadaur-454edb35fdabb417980420963443bff2c1c678a2.tar.gz
PKGBUILD cleanups
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index de46a46c5ed4..0744cb765d5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
pkgbase=python-google-auth-httplib2-git
pkgname=(python-google-auth-httplib2-git python2-google-auth-httplib2-git)
pkgver=r8.e7cd722
-pkgrel=1
+pkgrel=2
pkgdesc="Google Authentication Library: httplib2 transport"
url="https://github.com/GoogleCloudPlatform/google-auth-library-python-httplib2"
license=('Apache')
arch=('any')
makedepends=('python-setuptools' 'python2-setuptools' 'python-google-auth' 'python2-google-auth'
- 'python-httplib2' 'python2-httplib2' 'python-six' 'python2-six')
+ 'python-httplib2' 'python2-httplib2' 'python-six' 'python2-six' 'git')
checkdepends=('python-pytest-runner' 'python2-pytest-runner' 'python-mock' 'python2-mock'
'python-flask' 'python2-flask' 'python-pytest-localserver'
'python2-pytest-localserver')
@@ -29,7 +29,7 @@ prepare() {
}
build() {
- cd "$srcdir/google-auth-library-python-httplib2"
+ cd google-auth-library-python-httplib2
python setup.py build
cd "$srcdir/google-auth-library-python-httplib2-py2"
@@ -37,17 +37,17 @@ build() {
}
check() {
- cd "$srcdir/google-auth-library-python-httplib2"
+ cd google-auth-library-python-httplib2
python setup.py pytest
- cd "$srcdir/google-auth-library-python-httplib2"
+ cd "$srcdir/google-auth-library-python-httplib2-py2"
python2 setup.py pytest
}
package_python-google-auth-httplib2-git() {
depends=('python-google-auth' 'python-httplib2' 'python-six')
- cd "google-auth-library-python-httplib2"
+ cd google-auth-library-python-httplib2
python setup.py install --root="$pkgdir" --optimize=1
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
@@ -55,7 +55,7 @@ package_python-google-auth-httplib2-git() {
package_python2-google-auth-httplib2-git() {
depends=('python2-google-auth' 'python2-httplib2' 'python2-six')
- cd "google-auth-library-python-httplib2-py2"
+ cd google-auth-library-python-httplib2-py2
python2 setup.py install --root="$pkgdir" --optimize=1
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}