summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKaizhao Zhang2021-02-18 17:28:50 +0800
committerKaizhao Zhang2021-02-18 17:28:50 +0800
commitbcf76d309f08ac056d2e0c1ee72d99d22a5cc2c0 (patch)
tree2cf0a6a573c62a3aff6c370cccdcafa87265e139 /PKGBUILD
parent4b713f386fd34d1a66e50b0f613435a32e3e7bf8 (diff)
downloadaur-bcf76d309f08ac056d2e0c1ee72d99d22a5cc2c0.tar.gz
Updated to version 1.1.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1e56a55bf847..b53ce46fbc90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,27 +3,32 @@
_name=google-crc32c
pkgname=python-google-crc32c
-pkgver=1.0.0
+pkgver=1.1.2
pkgrel=1
pkgdesc="A python wrapper of the C library 'Google CRC32C'"
arch=('any')
url="https://pypi.org/project/google-crc32c/"
license=('APACHE')
depends=(
- 'python>=3.5'
+ 'python>=3.6'
'python-cffi>=1.0.0'
)
makedepends=('python-setuptools')
+optdepends=(
+ 'google-crc32c: using the c extension instead of a pure python implementation'
+)
options=(!emptydirs)
source=(
"https://files.pythonhosted.org/packages/source/${_name:0:1}/${_name}/${_name}-${pkgver}.tar.gz"
)
sha256sums=(
- '9439b960b6ecd847557675d130fc3626d762bf535da595c20a6949a705fb3eae'
+ 'dff5bd1236737f66950999d25de7a78144548ebac7788d30ada8c1b6ead60b27'
)
build() {
- # Google CRC32C is complex to compile at the moment. So only the pure Python implementation is used currently.
+ # Google CRC32C package is now here https://aur.archlinux.org/packages/google-crc32c/ .
+ # But its install prefix is `/usr/local`.
+ # To use it you need to change its install prefix to `/usr`.
cd "${srcdir}/${_name}-${pkgver}"
python setup.py build