summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2022-03-01 21:38:53 -0600
committerLuis Martinez2022-03-01 21:38:53 -0600
commitf4cc659a4cb5665151cb099de3cb6ab5df5b1642 (patch)
tree4ea7322f0bcb92c84bd1f284790f2f492c05c89a /PKGBUILD
parent767fff4b3a0b056e76766d8ed8889c5cadbd326a (diff)
downloadaur-f4cc659a4cb5665151cb099de3cb6ab5df5b1642.tar.gz
use python-installer for packaging
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5b6259cac671..3cf4e8a97edc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=python-googlemaps
pkgver=4.6.0
-pkgrel=1
+pkgrel=2
pkgdesc="Python client library for Google Maps Platform"
url="https://github.com/googlemaps/google-maps-services-python"
arch=('any')
license=('Apache')
depends=('python-requests')
-makedepends=('python-setuptools' 'python-build' 'python-install' 'python-wheel')
+makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel')
checkdepends=('python-pytest' 'python-responses')
changelog=CHANGELOG.md
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
@@ -16,7 +16,7 @@ sha256sums=('fd70fc848940cc3db652f20557de31feeb966065c6d1ca9c8967470867119ff6')
build() {
cd "google-maps-services-python-$pkgver"
- python -m build --wheel --skip-dependency-check --no-isolation
+ python -m build --wheel --no-isolation
}
check() {
@@ -27,5 +27,5 @@ check() {
package() {
export PYTHONHASHSEED=0
cd "google-maps-services-python-$pkgver"
- python -m install --optimize=1 --destdir="$pkgdir/" dist/*.whl
+ python -m installer --destdir="$pkgdir/" dist/*.whl
}