summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatthew Murray2020-06-23 10:50:58 +0100
committerMatthew Murray2020-08-24 08:52:36 +0100
commit9477525a0c6462fee55b3acc23a9587cb27e6d1d (patch)
tree6dfb22108fc2205495b907d4da348831b7e5c9e2 /PKGBUILD
downloadaur-9477525a0c6462fee55b3acc23a9587cb27e6d1d.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4e560b90f6f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Matthew Murray <matt@compti.me>
+pkgname=python-gphotos-sync
+_pkgname=gphotos-sync
+pkgver=2.14.2
+pkgrel=1
+pkgdesc="Google Photos and Albums backup with Google Photos Library API"
+arch=('any')
+license=('MIT')
+depends=("python" "python-attrs" "python-exif" "python-appdirs" "python-requests-oauthlib" "python-pyaml" "python-psutil")
+makedepends=("python" "python-setuptools")
+url="https://github.com/gilesknap/${_pkgname}"
+source=("${url}/archive/$pkgver.tar.gz")
+md5sums=('88fd01f0852c3410106ca75c4d4c92e8')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --prefix=/usr --root "${pkgdir}" || return 1
+
+ # TODO Include service file
+}
+
+# vim:set ts=2 sw=2 et: