summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrew Sun2020-07-26 11:47:43 -0400
committerAndrew Sun2020-07-26 11:47:43 -0400
commitcd6b116c19c974b3dd9eff2e2749572d2573caab (patch)
tree64dc0dae721ff301571aed67d07d4f4a62ff8cae /PKGBUILD
parentfe46f451841467bab6783e587c61c3c2e913427c (diff)
downloadaur-cd6b116c19c974b3dd9eff2e2749572d2573caab.tar.gz
remove python2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 6 insertions, 28 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7b858bb82cf3..f0202128ff60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,47 +1,25 @@
-# Maintainer: Andrew Sun <adsun701@gmail.com>
-# Contributor: Clint Valentine <valentine.clint@gmail.com>
+# Contributor: Andrew Sun <adsun701 at gmail dot com>
+# Contributor: Clint Valentine <valentine dot clint at gmail dot com>
_name=gtfparse
-pkgbase='python-gtfparse'
-pkgname=('python-gtfparse' 'python2-gtfparse')
+pkgname='python-gtfparse'
pkgver=1.2.0
-pkgrel=2
+pkgrel=3
pkgdesc="Python library for parsing GTF files"
arch=('any')
url="https://pypi.python.org/pypi/gtfparse"
license=('Apache')
-makedepends=('python' 'python-setuptools' 'python-pypandoc' 'python2' 'python2-setuptools' 'python2-pypandoc')
+makedepends=('python' 'python-setuptools' 'python-pypandoc')
options=(!emptydirs)
source=("${pkgname}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/g/${_name}/${_name}-${pkgver}.tar.gz")
sha256sums=('2f27aa2b87eb43d613edabf27f9c11147dc595c8683b440ac1d88e9acdb85873')
-prepare() {
- cp -a "${srcdir}/${_name}-${pkgver}"{,-py2}
-
- cd "${srcdir}/${_name}-${pkgver}-py2"
- sed -i -e "s|#![ ]*/usr/bin/python$|#!/usr/bin/python2|" \
- -e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
- $(find . -name '*.py')
-}
-
build(){
cd "${srcdir}/${_name}-${pkgver}"
python setup.py build
-
- cd "${srcdir}/${_name}-${pkgver}-py2"
- python2 setup.py build
}
-package_python2-gtfparse() {
- depends=('python2' 'python2-numpy' 'python2-pandas')
-
- cd "${srcdir}/${_name}-${pkgver}-py2"
- python2 setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
-}
-
-package_python-gtfparse() {
- depends=('python' 'python-numpy' 'python-pandas')
-
+package() {
cd "${srcdir}/${_name}-${pkgver}"
python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
}