diff options
author | Antonio Bartalesi | 2023-07-29 14:00:36 +0200 |
---|---|---|
committer | Antonio Bartalesi | 2023-07-29 14:00:36 +0200 |
commit | 5a0df8b9f63617a8ca0ca61658e0d9533ce5adf3 (patch) | |
tree | 3875c12c77c64c1863a45f19797315525023378d /PKGBUILD | |
parent | d27ddb94fc59f161933821501f79922d4ed7c9ca (diff) | |
download | aur-5a0df8b9f63617a8ca0ca61658e0d9533ce5adf3.tar.gz |
upgpkg:3.0.4-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 17 |
1 files changed, 9 insertions, 8 deletions
@@ -2,25 +2,26 @@ _name=guidata pkgname=python-$_name -pkgver=2.3.1 +pkgver=3.0.4 +_pkgver=v$pkgver pkgrel=1 pkgdesc="Python library generating graphical user interfaces for easy dataset editing and display" arch=('any') url='https://github.com/PierreRaybaut/guidata' -license=('custom:CeCILL') +license=('custom:BSD-3-clause') depends=(python-qtpy python-pyqt5-datavisualization python-pyqt5-webengine python-h5py python-pandas python-matplotlib python-beautifulsoup4 python-sphinx) -makedepends=(python-setuptools) +makedepends=(python-build python-installer python-wheel) optdepends=('spyder: GUI-based test launcher, dict/array editor') -source=("$_name-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz") -sha256sums=('9d8104826ca76c8bed79ab8f680cc6a40e74547ce3fb3d04ca6cb57ddeac1819') +source=("$_name-$pkgver.tar.gz::https://github.com/Codra-Ingenierie-Informatique/$_name/archive/refs/tags/$_pkgver.tar.gz") +sha256sums=('4f109b647d2ab9bc45a1517ff0b72f1866ff11669a6b0396c0d694c621e7514c') build() { cd "$_name-$pkgver" - python setup.py build + python -m build --wheel --no-isolation } package() { cd "$_name-$pkgver" - python setup.py install --root="$pkgdir" --optimize=1 --skip-build - install -Dm644 Licence_CeCILL_V2-en.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt" + python -m installer --destdir="$pkgdir" dist/*.whl + install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt" } |