summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Oelmueller2021-05-04 00:21:04 +0200
committerChris Oelmueller2021-05-04 00:21:04 +0200
commitfb76a3605d3cdf27e5bec942c5138209d81cc4ec (patch)
tree53036a9626206be061e0571ec8c7ff64d64e0a8d /PKGBUILD
downloadaur-fb76a3605d3cdf27e5bec942c5138209d81cc4ec.tar.gz
python-gvgen
GvGen is a python class to generate dot files for use with Graphviz
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..da3fc590ab52
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Chris Oelmueller <chris.oelmueller@gmail.com>
+# Contributor: Han Xiao <arak.hx@gmail.com>
+
+pkgname=python-gvgen
+_name=${pkgname#python-}
+pkgver=1.0
+pkgrel=1
+pkgdesc='Generates dot language files for easy scripting, to be processed with graphviz.'
+arch=('any')
+url='https://github.com/stricaud/gvgen'
+license=('GPL2')
+depends=('python2')
+makedepends=()
+source=("https://github.com/stricaud/${_name}/archive/refs/tags/v${pkgver}.tar.gz")
+md5sums=('4f7430fbe65eee5d93c64b8f063b806f')
+sha256sums=('47510a6eb70a7a435bdcdf56e58b08a6bf3c8adf42e4ae5430d9fb9b7760872b')
+
+PYTHON='python'
+
+build() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ $PYTHON setup.py build
+}
+
+package() {
+ cd "$srcdir/${_name}-${pkgver}"
+ $PYTHON setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}