summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarcell Meszaros2024-01-05 01:47:57 +0100
committerMarcell Meszaros2024-01-05 01:47:57 +0100
commitc96cbd5121d1318767a4c67c70c19ce46e9d2e0d (patch)
treee858ed63e9856e9d33f471c2355b0ede94dc1fac /PKGBUILD
parent55aa5a418343cd963fe24f309264b61332b795fe (diff)
downloadaur-python-gym-git.tar.gz
update build system & upstream URL
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 15 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e8c7d03d3bd1..2650bf4948f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,23 @@
_gitname=gym
pkgname=python-${_gitname}-git
pkgver=0.26.2.r3.gdcd18584
-pkgrel=1
+pkgrel=2
pkgdesc="A toolkit for developing and comparing reinforcement learning algorithms."
arch=('any')
-url="https://gym.openai.com"
+url='https://github.com/openai/gym#readme'
license=('MIT')
depends=(
'python'
'python-cloudpickle'
'python-numpy'
)
-makedepends=('git' 'python-setuptools')
+makedepends=(
+ 'git'
+ 'python-build'
+ 'python-installer'
+ 'python-setuptools'
+ 'python-wheel'
+)
provides=("python-gym=${pkgver%.r*}")
conflicts=('python-gym')
source=("git+https://github.com/openai/$_gitname")
@@ -35,9 +41,14 @@ pkgver() {
-e 's;\(post.*\);\.\1;'
}
+build() {
+ cd "${_gitname}"
+ python -m build --wheel --no-isolation
+}
+
package() {
cd "${_gitname}"
- python setup.py install --root="$pkgdir/" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm 644 README.md "$pkgdir/usr/share/doc/${pkgname}/README.md"
install -Dm 644 LICENSE.md "$pkgdir/usr/share/licenses/${pkgname}/LICENSE.md"
}