summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoracxz2020-01-17 20:24:53 -0500
committeracxz2020-01-17 20:24:53 -0500
commit144ad75c7d220825b1e712d5a5edd2e59611a7ce (patch)
tree1f348012e4a59117f473cb00d6cf10fee2617faf /PKGBUILD
downloadaur-python-gym-jsbsim-git.tar.gz
create python-gym-jsbsim-git package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3dfb6c8e90bc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: acxz <akashpatel2008 at yahoo dot com>
+
+pkgname=python-gym-jsbsim-git
+pkgver=r241.02b1882
+pkgrel=1
+pkgdesc='A reinforcement learning environment for aircraft control using the
+JSBSim flight dynamics model'
+arch=('x86_64')
+url='https://github.com/Gor-Ren/gym-jsbsim'
+license=('MIT')
+depends=('python' 'python-jsbsim' 'python-gym' 'python-numpy'
+ 'python-matplotlib')
+optdepends=('flightgear')
+makedepends=('python' 'python-setuptools')
+conflicts=('python-gym-jsbsim')
+provides=('python-gym-jsbsim')
+source=("git+https://github.com/Gor-Ren/gym-jsbsim")
+sha256sums=('SKIP')
+
+_pkgname=gym-jsbsim
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ python setup.py install --root="$pkgdir"/ --optimize=1
+}