summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGrey Christoforo2018-03-04 12:57:25 +0000
committerGrey Christoforo2018-03-04 12:57:25 +0000
commite8e847db4db03710e4da69e93464045a1ad913ee (patch)
tree5d3ca086b690eb1b116d13a45a976cb66acb4514 /PKGBUILD
downloadaur-e8e847db4db03710e4da69e93464045a1ad913ee.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0efe172798ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# $Id$
+# Maintainer: Grey Christoforo <first name at last name dot net>
+
+_pkg=h5py
+pkgbase=python-${_pkg}-git
+pkgname=(python-${_pkg}-git python2-${_pkg}-git)
+pkgver=r968.3d1edda
+pkgrel=1
+pkgdesc="General-purpose Python bindings for the HDF5 library -- latest commit, with mpi"
+url="http://www.h5py.org/"
+arch=('x86_64')
+license=('BSD')
+makedepends=("hdf5-openmpi" 'cython' 'cython2' 'python-numpy' 'python2-numpy' 'python-six' 'python2-six'
+ 'python-pkgconfig' 'python2-pkgconfig' 'python-mpi4py' 'python2-mpi4py')
+provides=(python-${_pkg} python2-${_pkg})
+conflics=${provides}
+
+source=("${_pkg}"'::git+https://github.com/h5py/h5py.git#branch=master')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_pkg}"
+ printf "r%s.%s" "$(git rev-list HEAD --count --first-parent)" "$(git rev-parse --short HEAD)"
+}
+
+package_python2-h5py-git() {
+ depends=('hdf5-openmpi' 'cython2' 'python2-numpy' 'python2-six' 'python2-pkgconfig' 'python2-mpi4py')
+ cd "${_pkg}"
+ python2 setup.py configure --mpi
+ python2 setup.py install --root="${pkgdir}" --optimize 1
+ #install -d644 "${pkgdir}/usr/share/licenses/${pkgname}"
+ #install -Dm644 "./licenses/*" "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -D licenses/license.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+
+package_python-h5py-git() {
+ depends=('hdf5-openmpi' 'cython' 'python-numpy' 'python-six' 'python-pkgconfig' 'python-mpi4py')
+ cd "${_pkg}"
+ python2 setup.py configure --mpi
+ python setup.py install --root="${pkgdir}" --optimize 1
+ #install -d644 "${pkgdir}/usr/share/licenses/${pkgname}"
+ #install -Dm644 "./licenses/*" "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -D licenses/license.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+